CMake: drop support for cmake < 3.5
[openjpeg.git] / src / bin / jp2 / CMakeLists.txt
index 29b4dd2088db7c86a32508a7c51d45be53e8a415..26156bcbfe3fe227c4be3e6c1567bef38e53767e 100644 (file)
@@ -44,9 +44,7 @@ endif()
 # Loop over all executables:
 foreach(exe opj_decompress opj_compress opj_dump)
   add_executable(${exe} ${exe}.c ${common_SRCS})
-  if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
-    target_compile_options(${exe} PRIVATE ${OPENJP2_COMPILE_OPTIONS})
-  endif()
+  target_compile_options(${exe} PRIVATE ${OPENJP2_COMPILE_OPTIONS})
   target_link_libraries(${exe} ${OPENJPEG_LIBRARY_NAME}
     ${PNG_LIBNAME} ${TIFF_LIBNAME} ${LCMS_LIBNAME}
     )