Merge master; fix crash on new film.
[dcpomatic.git] / debian / rules
index ba42e5291fabb5689821c7eee5ba168a9a964063..17594701970869bd061c1f082cfdeb531c5607b0 100755 (executable)
@@ -13,7 +13,8 @@
        dh $@ 
 
 override_dh_auto_configure:
-       ./waf --nocache configure --prefix=/usr --static
+       LINKFLAGS=$(CDIST_LINKFLAGS) CXXFLAGS="$(CXXFLAGS) $(CDIST_CXXFLAGS)" PKG_CONFIG_PATH=$(CDIST_PKG_CONFIG_PATH) \
+                ./waf --nocache configure --prefix=/usr --static --enable-debug
 
 override_dh_auto_build:
        ./waf --nocache build
@@ -21,3 +22,6 @@ override_dh_auto_build:
 override_dh_auto_install:
        ./waf --nocache install --destdir=debian/dcpomatic
 
+.PHONY: override_dh_strip
+override_dh_strip:
+       dh_strip --dbg-package=dvdomatic-dbg